
MimarSinan Visual Zip Studio
Welcome to MimarSinan Visual Zip Studio 98!

Please click "Contents" to see available books on using the Studio. Visual Zip Studio is the new wave in 
archive management, and it has a lot of features that are unmatched in other utilites!

But what is Visual Zip Studio? Visual Zip Studio is a file compression utility that allows you to compress 
any number of files into a single file, a "zip" file; which you can later decompress to obtain the original 
files. Visual Zip Studio also decompresses zip files created by other utilities, such as PKZip, TurboZip, 
WinZip, etc.

You can use Visual Zip Studio to save space on your hard disk (compress those massive files), backup 
data (span zip files across floppy disks), install applications contained in zip files you obtain on the web, 
create zip files to upload for the web, repair zip files, and even make self extracting zip files!

So click "Contents" and read on: Ride the new wave in zip management!



Windows Integration
Visual Zip Studio is tightly integrated with Windows. You can zip and unzip files without needing to open 
the Studio! This is accomplished by means of shell extensions.

A shell extension is an addition to your operating system that allows it to perform tasks it could not do 
before. Visual Zip Studio comes with some shell extensions which this book describes. These shell 
extensions can by themselves do almost everything Visual Zip Studio can.

To access the shell extensions, run Windows Explorer (the shell) and right click on either a zip file, or a 
group of files. This will bring a list of available shell extensions to view.



"Add to Zip"
If you select a group of files and then right click, you may choose to "Add to Zip". This choice will bring up 
an "Add to Zip" window from which you can choose your zip settings.

If you are an advanced user, you may want to review and change the zip settings. If not, just click "OK" 
and a new zip file will be created instantly which contains all your selected files!



"Extract"
If you select one or more than one zip file and right click, you may choose to "Extract". If you choose so, 
you will be able to unzip all of the files contained in the selected files.

If you are an advanced user, you may want to review and change the settings. If not, just click "OK" for 
the unzip to take place!

Note that you can select as many zip files as you want, and you can unzip them all at the same time, 
even to different folders if you wish!



"Make EXE"
If you select a single zip file and right click, you can choose "Make EXE". This choice will summon the 
Self Extracting EXE Wizard, which can convert your selected file into a self extracting file.



The Visual Studio
MimarSinan Visual Zip Studio is a very powerful environment to manage as many zip files as you want, 
up to and including all of the zip files on your hard drive! This section contains documentation for all the 
features of the Visual Studio.



Running for the First Time
Below are some steps that will configure Visual Zip Studio for your optimal use. It is recommended that 
you follow these steps the first time you run Visual Zip Studio. 
If you wish, you may skip this section and try the Setup Wizard instead. The Setup Wizard will configure 
Visual Zip Studio automatically, based on answers you give to a few questions.

Before following the actions in this book, make sure you have Visual Zip Studio running: Start->Programs-
>MimarSinan VZip->Visual Zip Studio.



Favorite Zip Folders
"Favorite Zip Folders" is a list of folders on your computer that contains the names of folders that have zip
files in them. Using this list, you can access immediately any and all of your zip files! To set up your 
favorite zip folders:

1. Click the Tools menu, then click Settings.
2. Click Zip Folders, then click Locations.
3. Click Search My Hard Disks Now, and wait for the search to complete.

Click "Accept", then click the File menu, Favorites, Update Favorites. All your zip files will now be listed 
under "Zip Neighborhood" for immediate access! To open a file, just click it (note that all zip files will be 
short-cutted but not opened).



Thread Priorities
Threads are parts of the Studio that perform certain tasks, such as zipping and unzipping. When you are 
zipping or unzipping a file, the process typically slows your computer down, since data is flowing through 
your processor. But you may want to still keep working with a responsive computer at hand! For this, you 
can assign priorities - a unique feature of the Studio! Do the following to set priorities:

1. Click the Tools menu, then click Settings.
2. Click Threads, then click Priorities.
3. From the drop-down list on the left, select a task - a thread.
4. From the drop-down list on the right, assign a priority.
5. Repeat this process for all threads.

Click "Accept" and your settings will be active! Note that it is not advisable to set the priority of your tasks 
higher than "Higher". Higher priorities may cause your system to stop responding. Generally, only three 
priorities are useful: "Low", "Normal", and "Higher".



User Interface Elements
You can customize the looks and behavior of the Studio to suit your taste. You can automate common 
tasks, and change some tree text. Do the following:

1. Click the Tools menu, then click Settings.
2. Click General, then click Visual.
3. Select your visual preferences.
4. Click Stepsavers.
5. Choose your stepsavers.

Click "Accept" and your settings will be immediately active! (Except for the hide toolbar bitmap selection)



Navigating Displays
The displays of the Visual Studio resemble that of Windows Explorer, as you may have noticed. This book
outlines how you can navigate the displays, to see the contents of a zip file, add remove and extract items
from a zip file, browse your favorite zip files, etc.



The Tree View
The tree view is the display on the left. When you first run the Studio, this tree view contains the following 
items:

"Visual Zip Desktop", denoting the current display.
"My Zip Files", denoting any zip files you create and open.
"Zip Neighborhood", denoting the folders on your computer which contain zip files, and containing 
shortcuts to those files. To open a file in the neighborhood, simply click on it.

When you open a file, a drive icon will appear bearing the name of the zip file just opened. This icon 
represents the zip file and all of its contents. If the zip file has folders in it, you can click the plus sign to 
the left of the drive icon to see them. You can click on the drive icon or on one of the folder icons to see 
their contents.

To select all the files inside a folder, click on the folder icon (the drive icon is considered to be the main 
folder). To deselect, click again.

If you want to select all of the files inside a folder, and the folders beneath it as well, make sure there is a 
plus sign to the next of the folder icon.



The File List
The file list contains a list of the files inside your selected zip file.

To select a file, click on it. To deselect, click again. To select a group of files, simply drag the mouse over 
the region.

To view a file, double click it. It will be opened in its native program, if it is a document. If it is a document 
and you make changes which you save, you can apply those changes into the zip file automatically - the 
Studio will ask.

To ascend to the previous level on the hierarcy, click View->Back One Level.



Context Menus
You can right click on the tree view or the file list and a context menu will pop up, offering several choices 
of action.

The tree view context menu allows you to select a group of items, hide or reveal a group of items, open a 
group of items; or configure your favorite zip folders. Some selections will be available only when a 
certain item is selected in the tree view.

The file list context menu allows you to customize the way the icons appear in the file list, and the way 
they are sorted.



Getting Results
This book outlines what you need to do to perform some fundamental and key tasks of the Studio.



Refreshing the Zip Neighborhood
If you make changes to your zip files outside of Visual Zip Studio, while the Studio is still active, you may 
need to refresh the contents of the Zip Neighborhood. To do so:

Click File->Favorites->Update Favorites.



Opening a Group of Files in the Zip Neighborhood
You can automatically open all or some of the files inside your zip neighborhood:

1. Click on either a favorite zip folder, or the Zip Neighborhood itself.
2. Click File->Favorites->Open All Linked Files.

The Studio will open all of the zip files under the selected item automatically.



Refreshing a Zip File
You may want to refresh a zip file (that is, close it and re-open it) to update its contents. The Studio 
typically refreshes as needed, but if you modify your zip files outside of the Studio while the Studio is 
running, you may need a refresh:

1. Click the drive icon of the zip file.
2. Click File->Refresh Selected File.



Clone Copy and Move
You may want to clone, copy or move an existing zip file from within the Studio. To do so:

1. Click the drive icon of the zip file.
2. Click File->Clone/Copy/Move.

The Studio will carry out your desired action.



Drag and Drop
You can drag and drop files from the Windows Explorer into the file list. If you have a zip file selected, this
action will compress the dropped files into the selected zip file; if not you may create a new zip file.

You can also drap and drop zip files onto the tree view. All the files you drop will be opened by the Studio.



Installing Applications
Many applications today are distributed on the internet in the form of zip files. The zip files often contain 
setup programs which install the applications in question onto the users computer. To install an 
application inside a zip file:

1. Open the zip file and select its drive icon.
2. Click Unzip->Install Application in Selected Zip.

The Studio will initiate the installation on your behalf.



Finding Files Inside Zip Files
Visual Zip Studio enables you to search for files inside the zip files you have open in the Studio. To search
for a file inside a zip file:

1. Click View->Find.
2. Click Find File In Zip.
3. Enter the file name and click "Go".

The Studio will search all open files, and list any matches. You can double-click on a matching file to get 
to it.

Note that Visual Zip Studio can search your entire computer for files inside zip files. To make sure such is 
the case:

1. Make sure your favorite zip folders are current.
2. Open all of the files inside your zip folders.
3. Perform the search as above.



UUEncode/Decode of Files
Some older email systems are not capable of receiving binary attachments (zip files are binary 
attachments). If you wish to email them your zip files, you can do so by first encoding your zip files into 
plain text. This is called UUEncode. To do so:

1. Select the zip file you want to encode (click on its drive icon).
2. Click Tools->UUEncode Chosen Zip File.

If you receive such an encoded file, you will need to decode it before you can use it. To do so:

1. Click Tools->UUDecode Encoded File.



To Erase Temporary Files
Visual Zip Studio has temporary files for the operations it carries out - installations, views, etc. These get 
built up over time and can consume disk space although they are highly unneeded, if not absolutely. To 
get rid of these files:

1. Click Tools->Delete Temporary Files.



Version Information
You may want to view version information and other details on the Studio. This may be required for 
techical support:

1. Click Help->About.



The Toolbar
Every command available on the menu bar is also available in the toolbar, or the right click context-menu. 
To view descriptions of the items in the toolbar, simply rest your pointer over them and hints will pop up.

You may want to use the toolbar for rapid access to commands. You can also enable or disable certain 
toolbar features: To do so:

1. Click Tools->Settings.
2. Click General->Visual or General->Stepsavers and customize.



Accessories
Visual Zip Studio comes with some accessories that you can make use of to further your use and 
enjoyment of the Studio. This book describes these accessories.



EXE Maker
Visual Zip Studio's Self Extracting EXE Maker allows you to convert your zip files into self extracting exe 
files which do not need to have any unzip utility for decompression.

To Start the EXE Maker: Start->Programs->MimarSinan VZip->Tools->EXE Maker.

The EXE Maker can create three kinds of self extracting files. These kinds:

(1) Extract all the files into a selected folder,
(2) List all files inside the zip and extract chosen ones into a selected folder,
(3) Perform a software installation based on your settings.

The EXE Maker is also the only one of its kind which features code-signing. You can "sign" your exe files 
to prove that they are your genuine files. Thus the recipient of these files will rest assured. You will need 
private key files and credentials for this purpose.
For more information: http://www.verisign.com



ZIP Repair
Occasionally, a zip file you obtain may be damaged. You can then use this utility to recover from the 
damage. The utility can also make backup copies of the files to be repaired in case something goes 
wrong.

To Start the EXE Maker: Start->Programs->MimarSinan VZip->Tools->Zip Repair.



Performing Backups
You may want to backup data to floppy disks on a regular basis. You may use the Studio for this purpose: 
You can span zip files across as many floppy disks as needed:

1. Make sure your new zip file is created on a removable drive (ex: floppy disk).
2. Select "Enable Span".



Getting Help
If there are any issues that are not addressed in this manual, or you have problems using the Studio, 
have bugs to report, etc, please contact us:

http://www.mimarsinan.com
mailto:sinan@mimarsinan.com

Your requests will be promptly answered (a day) if Mimar Sinan is in session. Note that Visual Zip Studio 
is composed almost entirely of friendly, descriptive Wizards. Just read the instructions and you will be 
fine!



About Mimar Sinan International
Mimar Sinan International is dedicated to providing high quality shareware that gives pride to the notion of
shareware. Mimar Sinan insists that free software (most of our products are in fact freeware) CAN mean 
QUALITY software. We have several product lines:

Mevlana: For Power Users
Yunus Emre: For the Novice User
Charm: For the Developer

Mimar Sinan International is located at:

2910 Medical Arts Suite 106
Austin TX 78705-3306
USA

Our Web:

http://www.mimarsinan.com
mailto:sinan@mimarsinan.com

Partner with Mimar Sinan



What's New?
Service Release I for Visual Zip Studio 98 has the following improvements, described in brief:

The Studio now remembers your finer settings.
Context menus in the tree view have been expanded.
New commands have been added for your further pleasure.
A "Setup Wizard" has been added for ease of configuring the Studio.
Major program optimizations and stability improvements have been made.

Refer to the relevant books for more information on new features.



Setup Wizard
The Setup Wizard is to help the non technically oriented user configure Visual Zip Studio for top 
performance and relevant settings of her choosing. The Setup Wizard is run when Visual Zip Studio is 
being installed automatically, and may be run again to re-configure Visual Zip Studio.

To Start the Setup Wizard: Start->Programs->MimarSinan VZip->Tools->Setup Wizard.



(De)Selecting a Group of Zip Files
You may want to select an entire batch of zip files, specifically one of the following:

(i) Those located under "My Zip Files"
(ii) Those located under a particular Favorite Zip Folder
(iii) Those located under all Favorite Zip Folders

1. Click the owning group of the files
2. Click View->Select/Unselect All.



System Information
System Information enables you to see what operating system you have on your computer, and free 
resources remaining. This may be required for technical support. To view this information:

1. Click Help->About System.

This option may not be available on some systems, in particular the non-high end Windows platforms.



Getting the Most Recent Version
You may want to make sure that you have the most recent version of Visual Zip Studio in hand. For this 
purpose, Visual Zip Studio has a built-in feature that allows you to visit the live web site of Visual Zip 
Studio, and download updates as you deem necessary.

1. Click Help->Upgrade to Newest Version.



Other Software Titles
The following are other freeware/shareware titles that Mimar Sinan International delivers. Please click on 
the associated hyperlinks for live web information and instant downloads!

MimarSinan Visual Split Studio 98
Simply the best file splitting technology. If there is anything related to file splitting, VSplit does it: From self
uniting exe files with crc32 verification to specifying the exact names and sizes for each split piece on any
target media.
VSplit Home

MimarSinan Q Utilities
Designed for the beginning computer user with power in mind. Create self extracting zip files instantly 
using our award winning Visual Zip Interface, split files and unite them effortlessly using Mimar Sinan's 
advanced technology.
Q Home

MimarSinan Whirling Dervish 97
We have not forgotten Windows 3.1 users! Do accept our invitation to try the perfect taskbar clone - 
accurate to the slightest detail, even with tray icons.
Dervish Home

MimarSinan mBx 5 (Broken Charm)
Mimar Sinan International's unsurpassed file splitting engine. Split files without a single line of code! Use 
our engine. The engine is so powerful that even VSplit does not exhaust all its features!
mBx Home



Purchase Information
Mimar Sinan International, as a service to the computing world, makes available Visual Zip Studio free for
strictly personal use at home. You do not need to make any purchase to legally continue using this 
software if it is being used for your personal purposes only, and at your home. However:

In order to legally use Visual Zip Studio at any given organization, including but not limited to 
governments, corporations, and the like, and for any purpose, such as commercial or home use, you 
must purchase a Site License from Mimar Sinan International. The cost of this license is $200.
In order to legally distribute any Self Extracting EXE files that you create with Visual Zip Studio, you 
must purchase a Redistribution License from Mimar Sinan International. This license corresponds to the
Gold version of Visual Zip Studio. This license includes the benefits of the Site License. The cost of this 
license is $330.

Note that you are not entitled to technical support under the gratis single user license. You must 
subscribe for a yearly support plan. There are at present two support plans:
StandaCare: For all technical support issues. Fee: $50. 
PrioriCare: For premium technical support access. Fee: $80.

Payment may be mailed to the following address:

Sinan Karaca
2910 Medical Arts, Suite 106
Austin, TX 78705-3306

Checks made payable to Sinan Karaca are accepted. No cash please, unless your circumstances 
dictate.

The purchase of a Site or Redistribution License entitles the owner of the license to a custom made 
version of Visual Zip Studio bearing their logo, to be delivered upon payment. Only this custom version 
may be used to generate Self Extracting EXE files (if applicable) for distribution.



License Agreement

WARNING! If you do not understand the following or will not comply with the following, you are not 
allowed to install or use this product and must immediately remove it from your system. By installing or 
using this software you indicate your agreement with the following terms.

1. Grant of License:

a. Single User License: Allows one (1) user to install and use the software on a single personal 
computer only, and only for strictly personal use at home. Does not permit the distribution of "Self 
Extracting EXE Files".
b. Site License: Allows a given company, organization, or generally speaking "site" to install and use the 
software on all the computers on the "site", for personal or commercial use. Does not permit the 
distribution of "Self Extracting EXE Files".
c. Redistribution License: Includes the benefits of a site license, and permits the distribution of the "Self 
Extracting EXE Files". Also referred to as the Gold version of this product.

You are herein granted a gratis single user license, provided you are using this computer for purely 
personal purposes at home. Note that you are not entitled to technical support under this free license (you
may purchase a support plan).

2. Disclaimer:

Mimar Sinan International provides the accompanying software "as-is", without warranties of any kind, 
even including the implied warranty of fitness or merchantability for any particular purpose. Mimar Sinan 
International herein expressly disclaims all warranties on this software, either express or implied. Mimar 
Sinan International may not be held liable for any damages, incidental or consequential, occuring from the
use of the accompanying software, even if she has been advised of the possibility of such damage.

© Copyright 1997, 1998 Mimar Sinan International. All rights reserved.




